Excel – Como buscar uma informação sem PROCV

por Sensei Matsumoto em 8 de janeiro de 2016

Bem-vindo leitores do Social Bits. Dando continuidade ao artigo anterior, “Entendendo o PROCV” (http://www.socialbits.com.br/articles/238/dicas-excel-entendendo-o-procv) neste artigo vou mostrar uma solução para contornar o problema que a função PROCV não consegue fazer: retornar referências de uma tabela procurando para a esquerda.

Como foi citado anteriormente, a função PROCV faz a pesquisa de dados sempre da esquerda para direita, ou seja, ele não retorna dados de uma tabela que esteja a esquerda do campo de pesquisa, retornando “#N/D”.

Dica 17 – Buscar uma informação sem PROCV

  • nível: básico
  • recursos utilizados: função INDICE e função CORRESP
  • compatibilidade: todas versões do Excel
  • tempo de implementação: menos de 2 minutos

Para solucionar esta situação vou usar 2 funções, de modo que juntas vão dar o mesmo efeito do PROCV só que com efeito melhorado. Usarei as funções ÍNDICE e CORRESP de modo encadeado. Para você entender todo o mecanismo primeiro você deve entender o funcionamento de cada uma.

Função ÍNDICE

ÍNDICE(matriz;núm_linha;núm_coluna)

Esta função retorna o valor de uma matriz tabela segundo o número da linha e coluna indicada pelo usuário. Para melhor entendimento vou ilustrar um exemplo, considere a seguinte tabela de dados:

Se digitarmos a função “=INDICE(A2:D5;4;3)” em qualquer célula vazia obtemos o resultado “32”, isto porque o valor que está na quarta linha e na terceira coluna da tabela é o valor “32”. Simples não é? Agora vamos para outra função…

Função CORRESP

CORRESP(valor_procurado; matriz_procurada; [tipo_correspondência])

A sintaxe da função CORRESP tem os seguintes argumentos:

  • valor_procurado  Necessário. O valor que você deseja corresponder em matriz_procurada.O argumento valor_procurado pode ser um valor (número, texto ou valor lógico) ou uma referência de célula a um número, texto ou valor lógico.
  • matriz_procurada  Necessário. O intervalo de células que estão sendo pesquisadas.
  • tipo_correspondência  Opcional. O número -1, 0 ou 1. O argumento tipo_correspondência especifica como o Excel corresponde valor_procurado com os valores em matriz_procurada. O valor padrão desse argumento é 1.A tabela a seguir descreve como a função localiza valores com base na configuração do argumento tipo_correspondência.

Esta função é parecido com o PROCV, até mesmo na sua sintaxe, a diferença é que a função não retorna o valor da tabela e sim a posição que ela se encontra na tabela. Para exemplificar considere a tabela abaixo:

Se for digitado a fórmula “=CORRESP(“Y”;B2:B5;0)” em uma célula vazia ele vai retornar “2”. Explicando: “Y” é o valor a ser procurado (assim como no PROCV), B2:B5 é a matriz coluna de pesquisa, ou seja, onde será feito a pesquisa (diferente do PROCV que você seleciona várias colunas, aqui você especifica somente a coluna onde o dado poderá estar), “0” é o tipo de correspondência exato, ou seja, ele vai procurar exatamente o “Y” na tabela, se não encontrar retorna “#N/D”. Entendeu o funcionamento do CORRESP? É a mesma coisa que perguntar “em qual linha da coluna B se encontra o dado Y”?

Resumindo: a função CORRESP retorna o número da linha de um dado na tabela e não o próprio dado.

Solucionando o problema

Agora que você já sabe o funcionamento de cada função podemos resolver nosso problema. Vamos montar uma função composta usando ambos, ficando a sintaxe da seguinte forma:

INDICE(matriz;CORRESP(valor_procurado;matriz_coluna;tipo);coluna)

Enxergou o que vai dar? A função ÍNDICE retorna o dado de uma matriz segundo a informação da linha e coluna, acontece que na linha temos a função CORRESP que procura um valor dentro de uma matriz coluna, retornando a linha. Exemplificando vamos usar a mesma tabela da situação 3 do artigo anterior, aqui queremos saber o código do produto informando o nome do produto:

Na célula B8 ficaria da seguinte forma:

=INDICE(A2:D5;CORRESP(B7;B2:B5;0);1)

Onde “A2:D5” é a matriz de dados, “CORRESP(B7;B2:B5;0)” retorna o número da linha onde se encontra o valor digitado de B7 (produto) e “1” é a coluna da matriz de dados (código).

Com isso o problema foi resolvido! Vantagens ao usar este modo:

  • a tabela não precisa estar classificada;
  • você pode fazer a pesquisa livremente buscando o campo da esquerda ou direita.

É isso ai gente, aproveitem a dica! Até o próximo artigo.

Anúncios

Atividade I – Práticas Financeiras e Contábeis

1º)Quais as funções dos departamentos Financeiro e Contábil?

2º)Quais os cursos de graduação das áreas financeiras e contábeis

3º)O que é administração financeira?

4º)Cite ao menos 4 características de um gestor financeiro :

5º)O que é Capital de Giro ?

6º) A previsão de estoque é baseada de acordo com a __________________de vendas de um período

7º)O que é Sazonalidade

8º)Em uma rede de supermercados que metodo de reposição de estoque é utilizado para evitar a perda de produtos perecíveis.

9º)O que é Over Estoque

10º)Sem o uso da _______________________ seria impossível obter um controle de estoque eficiente e preciso nos dias atuais.